5/5/2022
The Omnipod 5 Automated Insulin Delivery System:
Now available for Omnipod User Ages 6 and Older

The Omnipod 5 is now available for current Omnipod users ages 6 and older. If you are a current Omnipod user and would like to initiate the upgrade process, this step-by-step guide will help you do that. Follow these steps to see if you are eligible for the new system:

  • Check your insurance coverage by calling Omnipod or clicking here.
  • Confirm which mail order or specialty pharmacy will be your supplier.
  • Once you have confirmed this information, send a message to your Berrie Center provider through Connect and request a prescription for the Omnipod 5. Please also list the name of the pharmacy where your prescription will be filled.

Please note, it is your responsibility to confirm that your insurance will cover the Omnipod 5 and to determine where the prescription will be filled. If your insurance informs you an authorization is required, please contact the Omnipod Benefits Portal to initiate this process. If you are using a Dexcom receiver, it will not work with the Omnipod 5. You must have a compatible smartphone for Dexcom G6 to start and stop a sensor and receive high and low alerts. The new Omnipod system will still use a PDM or compatible phone for dosing. Not all phones are compatible. At this time iPhones are NOT compatible. Check here for compatible devices. Do not worry if you have an iPhone, you will still be able to use a PDM for dosing.

Please contact the Berrie Center to receive training once you receive your Omnipod 5. More information can be found on the Omnipod site.